The FreeBSD Diary

The FreeBSD Diary (TM)

Providing practical examples since 1998

If you buy from Amazon USA, please support us by using this link.
[ HOME | TOPICS | INDEX | WEB RESOURCES | BOOKS | CONTRIBUTE | SEARCH | FEEDBACK | FAQ | FORUMS ]
FreeBSD Support
 New Topic  |  Go to Top  |  Go to Topic  |  Search  |  Log In   Newer Topic  |  Older Topic 
 Samba... weird issues...
Author: el_kab0ng 
Date:   12-12-00 18:56

Ok...as always this site has been the best resource for troubleshooting my problems with Samba...and it appears as though they are 99% fixed.

First a little background:
1. I read through the related information throughout the diary...
2. I ran all the diagnostic tools via Samba's page.

So far, nmb and smb both run fine on my box. I can connect via the local box to my open share, as well as net view them in WinNT. But when I try to "net use * \\SERVER\share" I get a network path not found issue.

Why can I net view the shares, if I can't net use them? The host is there...because I can ping/trace the box via NetBIOS name....yet can't mount to it... Any suggestions?

Reply To This Message
 
 Re: Samba... weird issues...
Author: el_kab0ng 
Date:   12-12-00 19:47

Blah...turned out to be a permissions error...I tested the theory by creating a default share to see how it could construct the home dir for the share....turns out it was all about permissions.

Let this be a lesson! Permissions are everything to Unix!!!

Reply To This Message
 
 Re: Samba... weird issues...
Author: Don Brearley 
Date:   13-12-00 16:12


What advantages does SAMBA over say, NFS? Which I could
also implement.

- Don

PS: hi marty.

Reply To This Message
 
 Re: Samba... weird issues...
Author: Dan Langille 
Date:   13-12-00 19:49

SAMBA allows a UNIX box to look like a WINDOWS NT server. So your windows boxes can see and use it.

Reply To This Message
 
 Re: Samba... Errors...
Author: el_kab0ng 
Date:   14-12-00 18:01

Everything seems to be running fine now, but I get a inetd[153]: netbios-sn/udp: bind: Address already in use error.....

Any clue as to how to stop that error? What could be conflicting with 137??

Reply To This Message
 
 Re: Samba... Errors...
Author: Dan Langille 
Date:   14-12-00 21:34

Does samba work anywy?

Reply To This Message
 
 Re: Samba... Errors...
Author: el_kab0ng 
Date:   18-12-00 19:10

Yeah...in fact, I made some system wide changes that I felt needed the box to be rebooted for....and that seems to have fixed the errors....=/

Reply To This Message
 
 Re: Samba... Errors...
Author: meaculpa 
Date:   29-12-00 13:40

> Everything seems to be running fine now, but I get a inetd[153]: netbios-sn/udp: bind: Address already in use error.....

> Any clue as to how to stop that error? What could be conflicting with 137??

check your /etc/services & /etc/protocols to make sure only your smbd and nmbd use it's port, not other daemon.

in addition, you could check "bind address" and "interface" options of your smb.conf...

Reply To This Message
 Forum List  |  Threaded View   Newer Topic  |  Older Topic 


 Forum List  |  Need a Login? Register Here 
 User Login
 User Name:
 Password:
 Remember my login:
   
 Forgot Your Password?
Enter your email address or user name below and a new password will be sent to the email address associated with your profile.
How to get the most out of the forum

phorum.org