The FreeBSD Diary

The FreeBSD Diary (TM)

Providing practical examples since 1998

If you buy from Amazon USA, please support us by using this link.
[ HOME | TOPICS | INDEX | WEB RESOURCES | BOOKS | CONTRIBUTE | SEARCH | FEEDBACK | FAQ | FORUMS ]
FreeBSD Support
 New Topic  |  Go to Top  |  Go to Topic  |  Search  |  Log In   Newer Topic  |  Older Topic 
 squid err: urlParse: Illegal character in hostname
Author: reiner 
Date:   10-11-00 12:20


now Im following the instruction on how to install squid proxy server, then when I execute "/usr/local/sbin/squid -NCd1" and error msg popup (whole message below), my rc.conf contains "hostname=myhostname.mylocaldomainame.net" already, I can ping my "hostname" already, what other file(s) should I configure? I sure I miss something. ;-(


thanks!
reiner


-----------------------------------------------------------------------------


2000/11/10 18:16:43| Starting Squid Cache version 2.3.STABLE3 for i386--freebsd4.1...
2000/11/10 18:16:43| Process ID 249
2000/11/10 18:16:43| With 360 file descriptors available
2000/11/10 18:16:43| Performing DNS Tests...
2000/11/10 18:16:43| Successful DNS name lookup tests...
2000/11/10 18:16:43| DNS Socket created on FD 4
2000/11/10 18:16:43| Adding nameserver 127.0.0.1 from /etc/resolv.conf
2000/11/10 18:16:43| Unlinkd pipe opened on FD 9
2000/11/10 18:16:43| Swap maxSize 102400 KB, estimated 7876 objects
2000/11/10 18:16:43| Target number of buckets: 157
2000/11/10 18:16:43| Using 8192 Store buckets
2000/11/10 18:16:43| Max Mem size: 8192 KB
2000/11/10 18:16:43| Max Swap size: 102400 KB
2000/11/10 18:16:43| Rebuilding storage in /usr/local/squid/cache (DIRTY)
2000/11/10 18:16:43| Set Current Directory to /usr/local/squid/cache
2000/11/10 18:16:43| urlParse: Illegal character in hostname 'myhostname.mylocaldomainame.net'
2000/11/10 18:16:43| assertion failed: HttpRequest.c:72: "request"
Abort


Reply To This Message
 
 RE: squid err: urlParse: Illegal character in host
Author: reiner 
Date:   13-11-00 03:52

I figure it out already the problem is:

in /etc/rc.conf my hostname is:

hostname=my_hostname.mylocaldomainame.net

so the correct should be:

hostname=myhostname.mylocaldomainame.net


hostname should'nt contain "_". So I conclude hostname and domainame should not contain special characters (am I right? :)). I'v learned from my mistakes :).. Maybe some newbie (like me) will encounter this kind of error, I hope what I share could help! :)


I have to read more!!! to learn :)





Reply To This Message
 Forum List  |  Threaded View   Newer Topic  |  Older Topic 


 Forum List  |  Need a Login? Register Here 
 User Login
 User Name:
 Password:
 Remember my login:
   
 Forgot Your Password?
Enter your email address or user name below and a new password will be sent to the email address associated with your profile.
How to get the most out of the forum

phorum.org