The FreeBSD Diary

The FreeBSD Diary (TM) Remember
I remember
[ HOME | TOPICS | INDEX | WEB RESOURCES | BOOKS | CONTRIBUTE | SEARCH | FEEDBACK | FAQ | FORUMS ]

 New Topic  |  Go to Top  |  Go to Topic  |  Search  |  Log In   Newer Topic  |  Older Topic 
 /dev/sysmouse
Author: Andrei Popov 
Date:   01-01-02 19:44

<p>For some reason X works just fine here with <tt>/dev/sysmouse</tt>:</p>

<pre>
Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Device" "/dev/sysmouse"
EndSection
</pre>

<p>Granted, this does not allow foe using my mouse wheel (I've got a Logitech MouseMan+), but I have no problem whatsoever with clicking either of 3 buttons and getting a desired result.</p>
<p>Will, however, try your approach -- maybe it would be better than what I've got right now...</p>

Reply To This Message
 
 Re: /dev/sysmouse
Author: Dan Langille 
Date:   01-01-02 20:21

Hmmm, you don't have a protocol specified either.... Hmmm.

Reply To This Message
 
 Re: /dev/sysmouse
Author: Andrei Popov 
Date:   04-01-02 11:25

Just a guess -- `auto' is implied if not specified?

Reply To This Message
 
 Re: /dev/sysmouse
Author: Daniel O'Connor 
Date:   06-01-02 08:55

This works for me ->

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Device" "/dev/sysmouse"
Option "Protocol" "auto"
Option "Buttons" "6"
EndSection


I have a USB Logitech Trackman and the wheel works fine.

Reply To This Message
 
 Re: /dev/sysmouse
Author: steve ellis 
Date:   29-11-02 04:42

thanks!!!
i spent hours editing, reading, etc.,until i saw your article.
i made your changes, and Voila!! it worked perfectly.
i commented out--
# Option "protocol" "SysMouse"
changed Option "Device "/dev/mouse" to
Option "Device" /dev/sysmouse as you suggested,
and it worked. WHY??

now for the rub. my X-4 runs with 'BSD 4.7 on drive ad1.
X-3 runs on ad0 under 'BSD 4.5; X-3 XF86Config calls it
Device "dev/mouse"
why are they killing us???
steve --and thanks again.

Reply To This Message
 
 Re: /dev/sysmouse
Author: patrick 
Date:   16-06-04 16:52

well the mouse did not work on mine either but I used your tip and it does now. So I am definitely giving you a tip of my cap. thanks

Reply To This Message
 Forum List  |  Threaded View   Newer Topic  |  Older Topic 


 Forum List  |  Need a Login? Register Here 
 User Login
 User Name:
 Password:
 Remember my login:
   
 Forgot Your Password?
Enter your email address or user name below and a new password will be sent to the email address associated with your profile.
How to get the most out of the forum

phorum.org