The FreeBSD Diary

The FreeBSD Diary (TM)

Providing practical examples since 1998

If you buy from Amazon USA, please support us by using this link.
[ HOME | TOPICS | INDEX | WEB RESOURCES | BOOKS | CONTRIBUTE | SEARCH | FEEDBACK | FAQ | FORUMS ]
FreeBSD Support
 New Topic  |  Go to Top  |  Go to Topic  |  Search  |  Log In   Newer Topic  |  Older Topic 
 Java 1.5.0 FreeBSD 4.10 error
Author: D0MZE 
Date:   22-10-04 02:51

Hey guys, I've been trying to get Java 1.5.0 working on my FreeBSD box 4.10. I got 1.4.2 installed succesfully.

When I type java -version i get the following:

java -version
Java HotSpot(TM) Client VM warning: Can't detect initial thread stack location - find_vma failed
Bad system call (core dumped)

I have linux_enable="YES" in my rc.conf
can always be seen when doing df:

linprocfs 4 4 0 100% /usr/compat/linux/proc

Now I'm wondering why I am getting this error? Anyone can help?

Note:
In my .profile i have the following:

JAVA_HOME=/usr/local/linux-sun-jdk1.5.0/; export JAVA_HOME
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin:$HOME/bin:$JAVA_HOME/bin; export PATH

Reply To This Message
 
 Re: Java 1.5.0 FreeBSD 4.10 error
Author: fianna 
Date:   30-10-04 07:43

hmm thats a good one.

Reply To This Message
 
 Re: Java 1.5.0 FreeBSD 4.10 error
Author: Rojo Loco 
Date:   08-11-04 22:12

I'm also having the same problem...

Reply To This Message
 
 Re: Java 1.5.0 FreeBSD 4.10 error
Author: heuwitt 
Date:   30-11-04 08:12

Same issue here. Only way I think is to ask Sun to release a version specifically for FreeBSD, rather making FreeBSD community to "hack" it and getting it to work thru Linux emulation. FreeBSD is a server platform that could no longer be ignored.

Reply To This Message
 
 Re: Java 1.5.0 FreeBSD 4.10 error
Author: JH Foo 
Date:   10-12-04 11:03

I'm trying to get Java 1.4 working on FreeBSD. Did you have any luck on a native installation?

Reply To This Message
 
 Re: Java 1.5.0 FreeBSD 4.10 error
Author: markcole 
Date:   20-01-05 04:16

FWIT, I read somewhere that 1.5 would not work on FreeBSD.

I spent a long time getting tomcat working, alot of it was wasted to get 1.5 working.

Sorry I cannot remember where I saw this....

-mark

Reply To This Message
 Forum List  |  Threaded View   Newer Topic  |  Older Topic 


 Forum List  |  Need a Login? Register Here 
 User Login
 User Name:
 Password:
 Remember my login:
   
 Forgot Your Password?
Enter your email address or user name below and a new password will be sent to the email address associated with your profile.
How to get the most out of the forum

phorum.org