The FreeBSD Diary

The FreeBSD Diary (TM)

Providing practical examples since 1998

If you buy from Amazon USA, please support us by using this link.
[ HOME | TOPICS | INDEX | WEB RESOURCES | BOOKS | CONTRIBUTE | SEARCH | FEEDBACK | FAQ | FORUMS ]
FreeBSD Support
 New Topic  |  Go to Top  |  Go to Topic  |  Search  |  Log In   Newer Topic  |  Older Topic 
 deinstall ports ?
Author: fuzzy-aztec 
Date:   12-02-03 12:36

hi, how can i deinstall a ports ?
well my problem is that the ports doesnt seem installed, simply it's not exist anything in /var/db/pkg
obviously make deinstall or pkg_delete -f pkg or pkg_deinstall -f pkg don't work because the pkg seems not installed.
thx

Reply To This Message
 
 Re: deinstall ports ?
Author: bb 
Date:   12-02-03 15:40

pretty sure you can just do a make deinstall from the /usr/ports/

in which it was built

Reply To This Message
 
 Re: deinstall ports ?
Author: fuzzy-aztec 
Date:   12-02-03 18:04

ok, I'll deinstall it by hand, thx :)

Reply To This Message
 
 Re: deinstall ports ?
Author: bb 
Date:   12-02-03 21:46

100% percent positive that works because i muffed up pine by installing it twice from the ports today (doh)

did a make deinstall and then a make && make install and all went smooth

Reply To This Message
 
 Re: deinstall ports ?
Author: .daniel.schrock 
Date:   12-02-03 22:37

it depends on the port... not all of them support make deinstall.

you should use portupgrade... its almost as easy as winblow's add/remove programs...

Reply To This Message
 
 Re: deinstall ports ?
Author: bb 
Date:   12-02-03 22:39

which ports doesnt make deinstall work on

just out of curiousity?

Reply To This Message
 
 Re: deinstall ports ?
Author: .daniel.schrock 
Date:   13-02-03 05:14

i couldn't tell you... but i do know that make deinstall has not worked for me in the past... they may have changed things since i last tried it.

i switched to portupgrade and haven't looked back since...

Reply To This Message
 
 Re: deinstall ports ?
Author: fuzzy-aztec 
Date:   13-02-03 13:37

yep, but the other problem is that also make install doesnt work :-|
the port is galeon2..
I had had these problems after a crash during a portupgrade -ar

Reply To This Message
 
 Re: deinstall ports ?
Author: fuzzy-aztec 
Date:   13-02-03 13:53

galeon2
-su-2.05b# cd /usr/ports/www/galeon2/
-su-2.05b# make deinstall
===> Deinstalling for galeon2-1.3.1_1
===> galeon2-1.3.1_1 not installed, skipping
-su-2.05b# ls /var/db/pkg/|grep -i galeon
-su-2.05b# which galeon
/usr/X11R6/bin/galeon
-su-2.05b#

Reply To This Message
 
 Re: deinstall ports ?
Author: .daniel.schrock 
Date:   13-02-03 17:58

rm -rf /usr/X11R6/bin/galeon

or try launching it and see if it really is `galeon2`... it may be the original `galeon`

Reply To This Message
 
 Re: deinstall ports ?
Author: fuzzy-aztec 
Date:   13-02-03 18:16

the problem is not if is galeon or galeon2, the problem is that one galeon is installed but it seems not installed, then i can not deinstall it.

Reply To This Message
 
 Re: deinstall ports ?
Author: .daniel.schrock 
Date:   13-02-03 20:01

well...the version does make a difference... they will have different md5 sums... if the sum of the file its trying to remove is different that the sum on the filesystem, its not going to remove that....
you could also just remove it by hand...
or you can attempt to deinstall all ports related to XFree86, wipe out the /usr/X11R6 directory and rebuild X from scratch using portinstall...

here is the bitch of the portupgrade utility... once you start using it, you have to always use it... always pkgdb -F after a make install... always use portupgrade to upgrade ports... always keep the your ports collection Index in sync with portupgrade (portsdb -Uu)...

if you don't do this, you fsck your system all up and the only way to regain sainity is remove all ports and start over....

Reply To This Message
 
 Re: deinstall ports ?
Author: fuzzy-aztec 
Date:   15-02-03 22:24

ok, that's all ok!!
the problem to compile galeon2 was that i had different version of mozilla browsers installed.
So I have deinstalled anyone mozilla pkgs and then i have reinstalled galeon2.
Anyway thanks very much for your help :)

Reply To This Message
 Forum List  |  Threaded View   Newer Topic  |  Older Topic 


 Forum List  |  Need a Login? Register Here 
 User Login
 User Name:
 Password:
 Remember my login:
   
 Forgot Your Password?
Enter your email address or user name below and a new password will be sent to the email address associated with your profile.
How to get the most out of the forum

phorum.org