The FreeBSD Diary

The FreeBSD Diary (TM)

Providing practical examples since 1998

If you buy from Amazon USA, please support us by using this link.
[ HOME | TOPICS | INDEX | WEB RESOURCES | BOOKS | CONTRIBUTE | SEARCH | FEEDBACK | FAQ | FORUMS ]
FreeBSD Support
 New Topic  |  Go to Top  |  Go to Topic  |  Search  |  Log In   Newer Topic  |  Older Topic 
 PPTP server problem
Author: MC 
Date:   05-02-03 04:22

Greetings,

Ive installed mpd in my freebsd 4.6 (at my work place behind a firewall) and configured it. I tried connecting from my WinXP Pro at home and this what i got at the freebsd side:

[pptp] CHAP: rec'd RESPONSE #2
Name: "vpntest"
Peer name: "vpntest"
Response is valid
[pptp] CHAP: sending SUCCESS
[pptp] LCP: authorization successful
[pptp] LCP: phase shift AUTHENTICATE --> NETWORK
[pptp] up: 1 link, total bandwidth 64000 bps
[pptp] IPCP: Up event
[pptp] IPCP: state change Starting --> Req-Sent
[pptp] IPCP: SendConfigReq #1
IPADDR 192.168.1.3
COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
[pptp] CCP: Open event
[pptp] CCP: state change Initial --> Starting
[pptp] CCP: LayerStart
[pptp] CCP: Up event
[pptp] CCP: state change Starting --> Req-Sent
[pptp] CCP: SendConfigReq #1
MPPC
0x01000060: MPPE, 40 bit, 128 bit, stateless
[pptp] CCP: rec'd Configure Request #1 link 0 (Req-Sent)
PRED1
Not supported
MPPC
0x000000e0: MPPE, 40 bit, 56 bit, 128 bit
[pptp] CCP: SendConfigRej #1
PRED1
[pptp] IPCP: rec'd Configure Request #1 link 0 (Req-Sent)
IPADDR 192.168.1.100
192.168.1.100 is OK
COMPPROTO VJCOMP, 16 comp. channels, allow comp-cid
[pptp] IPCP: SendConfigAck #1
IPADDR 192.168.1.100
COMPPROTO VJCOMP, 16 comp. channels, allow comp-cid
[pptp] IPCP: state change Req-Sent --> Ack-Sent
[pptp] IPCP: SendConfigReq #2
IPADDR 192.168.1.3
COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
[pptp] CCP: SendConfigReq #2
MPPC
0x01000060: MPPE, 40 bit, 128 bit, stateless
[pptp] IPCP: SendConfigReq #3
IPADDR 192.168.1.3
COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
[pptp] CCP: SendConfigReq #3
MPPC
0x01000060: MPPE, 40 bit, 128 bit, stateless
[pptp] IPCP: SendConfigReq #4
IPADDR 192.168.1.3
COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
[pptp] CCP: SendConfigReq #4
MPPC
0x01000060: MPPE, 40 bit, 128 bit, stateless
[pptp] IPCP: SendConfigReq #5
IPADDR 192.168.1.3
COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
[pptp] CCP: SendConfigReq #5
MPPC
0x01000060: MPPE, 40 bit, 128 bit, stateless
[pptp] IPCP: SendConfigReq #6
IPADDR 192.168.1.3
COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
[pptp] CCP: SendConfigReq #6
MPPC
0x01000060: MPPE, 40 bit, 128 bit, stateless
[pptp] IPCP: SendConfigReq #7
IPADDR 192.168.1.3
COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
[pptp] CCP: SendConfigReq #7
MPPC
0x01000060: MPPE, 40 bit, 128 bit, stateless
[pptp] IPCP: SendConfigReq #8
IPADDR 192.168.1.3
COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
[pptp] CCP: SendConfigReq #8
MPPC
0x01000060: MPPE, 40 bit, 128 bit, stateless
[pptp] IPCP: SendConfigReq #9
IPADDR 192.168.1.3
COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
[pptp] CCP: SendConfigReq #9
MPPC
0x01000060: MPPE, 40 bit, 128 bit, stateless
[pptp] IPCP: SendConfigReq #10
IPADDR 192.168.1.3
COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
[pptp] CCP: SendConfigReq #10
MPPC
0x01000060: MPPE, 40 bit, 128 bit, stateless
[pptp] IPCP: state change Ack-Sent --> Stopped
[pptp] IPCP: LayerFinish
[pptp] IPCP: parameter negotiation failed
[pptp] IPCP: LayerFinish
[pptp] CCP: state change Req-Sent --> Stopped
[pptp] CCP: LayerFinish
[pptp] CCP: parameter negotiation failed
[pptp] CCP: Close event
[pptp] CCP: state change Stopped --> Closed
[pptp] CCP: LayerFinish
[pptp] bundle: CLOSE event in state OPENED
[pptp] closing link "pptp"...
[pptp] bundle: CLOSE event in state CLOSED
[pptp] closing link "pptp"...
[pptp] link: CLOSE event
[pptp] LCP: Close event
[pptp] LCP: state change Opened --> Closing
[pptp] LCP: phase shift NETWORK --> TERMINATE
[pptp] up: 0 links, total bandwidth 9600 bps
[pptp] IPCP: Down event

The server can't seem to connect my winXP. Did i configure my mpd.conf wrong?

mpd.conf:
===========
default:
load pptp

# PPTP Server
pptp:
new -i ng0 pptp pptp

set bundle disable multilink
set bundle enable compression
set bundle enable encryption

set iface disable on-demand
set iface disable proxy-arp
set iface idle 0

set ipcp ranges 192.168.1.3/30 192.168.1.100/30
set ipcp dns 192.168.0.1
set ipcp enable vjcomp

set link enable acfcomp protocomp
set link disable pap
set link enable chap
set link keep-alive 10 60

set ccp enable mppc
set ccp enable mpp-compress
set ccp enable mpp-e40
set ccp enable mpp-e128
set ccp enable mpp-stateless

I cant seem to figure it out. Can anyone help me?

-MC-

Reply To This Message
 Forum List  |  Threaded View   Newer Topic  |  Older Topic 


 Forum List  |  Need a Login? Register Here 
 User Login
 User Name:
 Password:
 Remember my login:
   
 Forgot Your Password?
Enter your email address or user name below and a new password will be sent to the email address associated with your profile.
How to get the most out of the forum

phorum.org