The FreeBSD Diary

The FreeBSD Diary (TM)

Providing practical examples since 1998

If you buy from Amazon USA, please support us by using this link.
[ HOME | TOPICS | INDEX | WEB RESOURCES | BOOKS | CONTRIBUTE | SEARCH | FEEDBACK | FAQ | FORUMS ]
FreeBSD Support
 New Topic  |  Go to Top  |  Go to Topic  |  Search  |  Log In   Newer Topic  |  Older Topic 
 Installing FreeBSD 5.0 RELEASE from source
Author:  
Date:   25-01-03 14:30

I couldn't help trying to upgrade one small server running 4.7-STABLE to 5.0 RELEASE as soon as the RELENG_5_0_0_RELEASE cvs tag was made available.
But as i didn't want to blow up my 4-STABLE source tree (nfs shared on a MacosX server) i changed my cvsup config file to
*default base=/usr/src/5
*default prefix=/usr/src/5
After cvsuping, i made the classic buildworld, buildkernel, installkernel (reboot) then installworld && mergemaster without
any (major)problem.
But on the next reboot, my machine wouldn't allow to mount anything via nfs, complaining about Netconfig not being able to be configured. In fact no network service could work properly, and i couldn't even log in, the machine complaining about pam configuration files missing (i have to say that i mount /usr/local over nfs, due to the lack of space on my 1 Gb disk)
I then booted in signle user mode, and compared the contents of my newly installed /etc and the content of the src/etc directory on the nfs server. Just to see the a lot of files hadn't been installed, even though having gone through the whole mergemaster process without (i thought) any problem. After creating the /etc/netconfig by hand, and doing a /etc/netstart, i managed to nfs mount /usr/src again and try to redo a mergemaster from /usr/src/5/src (see my cvsup config) I then realised that mergemaster was complaining about missing files in /usr/src/etc (!) where it should have looked for files in /usr/src/5/src/etc. I then tried to fix this by symlinkning /usr/src/etc to /usr/src/5/src/etc and re-mergemaster. Everything worked fine this time, and next reboot went without a problem.
I never had problems like this formerly, when installing world from a non standard src location. Have things changed radically in the 5 version ? Has anybody had any kind of problem like that ? In fact i suspect that mounting /usr/src via nfs shared on MacOS X might be one of thereasons, as i have had a lot of trouble before being able to build world over nfs on macos.
I'd appreciate any comments or questions on this.
Thanks for reading, sorry for the possible english mistakes.
(Maybe I should have posted this to the "Success stories" section, but i don't consider it a success since i still don't know if i did it right)

Jessť

Reply To This Message
 Forum List  |  Threaded View   Newer Topic  |  Older Topic 


 Forum List  |  Need a Login? Register Here 
 User Login
 User Name:
 Password:
 Remember my login:
   
 Forgot Your Password?
Enter your email address or user name below and a new password will be sent to the email address associated with your profile.
How to get the most out of the forum

phorum.org