The FreeBSD Diary

The FreeBSD Diary (TM)

Providing practical examples since 1998

If you buy from Amazon USA, please support us by using this link.
[ HOME | TOPICS | INDEX | WEB RESOURCES | BOOKS | CONTRIBUTE | SEARCH | FEEDBACK | FAQ | FORUMS ]
FreeBSD Support
 New Topic  |  Go to Top  |  Go to Topic  |  Search  |  Log In   Previous Message  |  Next Message 
 zebra,ospf. Balansing howto?
Author: el 
Date:   25-09-06 13:45

Hi!

I made vpn (ipsec) on FreeBSD 6.1.
For providing uninterrupted network performance, I made reserve
channel connection with ADSL modem, added routes, installed zebra package.
But during testing the reserve channel connection is not UP after basic channel gets DOWN.


Diagram:
gif0(ipsec)
+----------------+
net1 / \ net2
-------+ +--------
\ /
\ /
+ ADSL----ADSL+



My zebra settings:

!
! Zebra configuration saved from vty
! 2006/09/14 14:06:20
!
hostname Router
password *****
enable password *****
log file /var/log/zebra/zebra.log
!
!
interface xl0
!ip address 192.168.166.107/24
ipv6 nd suppress-ra
multicast
!
interface ed0
! ip address 192.168.1.1/24
ipv6 nd suppress-ra
multicast
!
interface gif0
ipv6 nd suppress-ra
multicast
!
ip route 192.168.165.0/24 gif0
ip route 192.168.165.0/24 ed0
ip route 192.168.166.0/24 xl0
!
line vty
!


My ospf settings:

!
! Zebra configuration saved from vty
! 2006/09/14 16:46:34
!
hostname ospfd
password *****
log file /var/log/zebra/ospfd.log
!
interface xl0
!
interface ed0
!
interface gif0
ip ospf network point-to-point
!
router ospf
ospf router-id 192.168.166.107
network 0.0.0.0/0 area 0.0.0.0
network 192.168.166.0/24 area 0
network 192.168.165.0/24 area 0
redistribute connected
redistribute static
line vty
!



Help me, please.

 Reply To This Message  |  Forum List  |  Flat View   Newer Topic  |  Older Topic 

 Topics Author  Date
 zebra,ospf. Balansing howto?   new
el 25-09-06 13:45 


 Forum List  |  Need a Login? Register Here 
 User Login
 User Name:
 Password:
 Remember my login:
   
 Forgot Your Password?
Enter your email address or user name below and a new password will be sent to the email address associated with your profile.
How to get the most out of the forum

phorum.org